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As professional communicators, we often come 
across opportunities to stretch the conventional boundaries 
of our role. Consider this situation: your organization is 
planning to gather inputs from customers about product 
usage patterns and the features that they would like to 
see in future releases. While you can always help draft 
intelligent questions for the survey, wouldn’t it be nice if 
you could also devise a workflow to gather the required 
feedback and present it as tabular, actionable information? 
If I see you nodding yes, this article is just for you!

For many years now, PDF forms have remained a 
popular way to gather inputs from users within an organi-
zation’s firewall or across the Web. While such forms are 
intuitive for recipients to fill and submit, they are also 
surprisingly easy to create and distribute.

PDF forms also render well in print and fit seamlessly 
into the paper-based processes that still persist in many 
organizations. Think of a different scenario where form 
recipients are trying to get approvals to attend an event 
for which you’ve designed the registration form. They may 
have to submit printed copies of the filled-in form to several 
departments—finance, accounts, and training, to name 
a few. If the form in question is a PDF form, you can even 
offer snail mail as one of the modes by which recipients 
can submit the filled-in form, possibly with supporting 
documents or payment instruments.

Some Real-World Applications
You can create PDF forms for a variety of business 
purposes, such as the following:

44 Customer satisfaction survey
44 Help desk request
44 Feedback on products or services
44 Purchase order
44 Quote
44 Request for quote
44 Status reports
44 Editorial checklists
44 Handoff checklists
44 Performance appraisals

Prerequisites
Many professional communicators already have Adobe 
Acrobat Professional or Acrobat Pro Extended installed 
on their computers. If you’re one of them, you’re all set to 
create and distribute PDF forms. Acrobat Professional and 
Acrobat Pro Extended versions 7.0 and above bundle Adobe 
LiveCycle Designer, the native application for creating PDF 
forms. Acrobat X bundles LiveCycle Designer ES2.

After you’ve created and distributed the form, recipients 
can fill it in using Adobe Reader, Adobe Acrobat, or any 
other PDF reader application that supports completing and 
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scenarios. For instance, the sample form for this article 
is an extensively customized version of the Conference 
Registration template.

Follow these steps to begin creating a new form:
1.	 In Windows, click Start > Adobe LiveCycle ES2 > Adobe 

LiveCycle Designer ES2.
2.	 Click New Form in the Welcome to Adobe LiveCycle 

Designer ES2 dialog box.
3.	 In the New Form Assistant, select one of the following 

options:
88 Select Use a Blank Form if you want to create a form 
from scratch. 
88 If you want to customize an available form template 
according to your requirements, select Based on a 
Template.

4.	 Click Next.
5.	 Finish the New Form Assistant wizard by specifying the 

additional information requested. If you chose to model 
your form after a template, you’ll be asked to pick one of 
the many available templates. If you chose to create your 
form from scratch, specify page settings and the basic 
buttons that you’d want to add to it.
Once you’ve completed the New Form Assistant wizard, 

you can use intuitive, easy-to-use building blocks—such as 
text fields, numeric fields, text areas, drop-down lists, list 
boxes, and radio buttons—to design your form further.

Figure 2 shows the completed sample form in LiveCycle 
Designer, with the utilized building blocks labeled for easy 

submitting PDF forms. Adobe Reader is, of course, a free 
download available from Adobe.com.

For the purpose of this discussion, I’ve created a sample 
conference registration form using Acrobat Professional 
that we’ll discuss in detail as we move along. The form is 
posted online at http://blogs.adobe.com/samartha/files/2011/07/
Intercom_Sample_form.pdf; take a moment to familiarize 
yourself with it. Detailed instructions for recipients to fill 
and submit the form are included in the form itself.

Workflow
The workflow proposed in this article lets recipients send 
their filled-in forms directly to your email inbox. You 
can add these completed forms to a “responses” file that 
Acrobat automatically creates on your computer when you 
distribute the form. Further, you can manage, consolidate, 
and export the received data using Forms Tracker (http://
help.adobe.com/en_US/acrobat/standard/using/WS0C017BFC-
057C-4996-B1AE-7137093B41B4.html), a tracking utility 
provided by Acrobat that you can also access from the 
Windows system tray.

Refer to Figure 1 to understand the form workflow better.

Creating the Form
You can either create a form from scratch in LiveCycle 
Designer or modify an available form template according 
to your requirements. Designer provides numerous 
predesigned templates to fit different business needs and 

Figure 1. Form workflow
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to the user. You can change the default, numeric values 
for the members of a radio group on the Object – 
Binding page (3). For example, values for the FeeRadio 
radio button group in the sample form are “Paid” and 
“Exempted.”
44 When you add two radio buttons to the form consecu-
tively, they are automatically added to the same radio 
group. However, to make radio buttons that were not 
added consecutively to the form part of the same radio 
group, select1 all the radio buttons, right-click, and 
select Merge Radio Button Groups from the context-menu. 
However, if two radio buttons in the merged group have 
the same value, you will need to manually resolve the 
values on the Object – Binding page (3).

Previewing the Form
While you are designing a form, you can quickly preview 
the results in the Preview tab.

Ensuring Compatibility with  
Older PDF Reader Software

Perform the following steps to ensure that recipients 
using older versions of PDF reader software will be able to 
complete and submit the form:
1.	 In LiveCycle Designer, click File > Form Properties > 

Defaults.
2.	 Choose Acrobat and Adobe Reader 7.0.5 or Later from the 

Choose Version To Run Form In drop-down menu.
3.	 Click OK.
1      Click and drag to form a selection rectangle that encloses all the radio buttons.

identification. Compare this figure with the actual form 
linked to earlier in this article.

Note: If you’re unable to see a palette labeled in Figure 
1, you can choose it for display from the Window menu. For 
example, select Window > Object.

Key Considerations
As you design your form, keep the following important 
considerations in mind:

44 Include instructions for completing and submitting the 
form. See the sample form.
44 Wherever necessary, include tool-tips for fields. You can 
create tool-tips on the Accessibility page (labeled 4 in 
Figure 2). See the sample form.
44 Assign a unique, easy-to-remember Name to each field 
on the Object – Binding page (3). You’ll use this name 
later to interpret the data in the responses and create 
field-level controls using JavaScript or FormCalc scripting.
44 To make a field mandatory for users to fill-in, select User 
Entered – Required for the field from the Type drop-down 
menu on the Object – Value page (2).
44 You can specify available options for drop-down lists and 
list boxes on the Object – Field page (1). These options 
are automatically assigned unique numeric values, 
which may be difficult to track if you have many users 
registering. You can modify these default values on the 
Object – Binding page (3) and assign easy-to-track text 
values to the options.
44 Radio buttons are added to the form in mutually 
exclusive groups to provide “one out of many” choices 

Figure 2. The completed sample form in LiveCycle Designer

1. Object – Field  |  2. Object – Value  |  3. Object – Binding  |  4. Accessibility   
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When you distribute the form, Acrobat automatically 
adds your registered email ID to it, so that users can submit 
the filled-in forms to you by email.

If you intend to distribute the form to recipients within 
your organization’s firewall, you can share the [form 
name]_distributed.pdf file on the intranet or place it on 
shared storage and then communicate the location of the 
file to the recipients. Alternatively, you can attach the [form 
name]_distributed.pdf file with an email message and send 
it to recipients for an end-to-end email-based workflow.

Managing Responses
Filled-in forms arrive as email attachments in the mailbox 
of the identified point of contact who distributed the form. 
If the recipient submitted the form through an email client, 
such as Microsoft Outlook, the subject line of the email 
with the response attached is Submitting Completed Form. 
However, the subject line of the email may differ if the 
recipient submits the form using a Web email account, such 
as a Gmail or Yahoo! account.

Perform the following steps once you receive a 
completed form:
1.	 Double-click the attachment from the email and wait for 

Adobe Acrobat to open it.
2.	 In the Add Completed Form to Responses File dialog 

box, ensure that the correct [form_name]_responses.pdf 
file is selected and click OK. Acrobat will add the 
response and open Adobe Tracker to display all 
responses received so far.

Distributing the Form
After you’ve created the form, you need to distribute it to 
the intended recipients. The following steps represent a 
good distribution strategy for the sample form, considering 
that the conference has 200–300 delegates registering:
1.	 Save the file as a PDF form file to a dedicated folder. 

This folder should be retained until the registration 
drive for the conference is complete.

2.	 In LiveCycle Designer, with the form open, click File > 
Distribute Form. LiveCycle Designer launches Acrobat 
with the Distribute Form dialog displayed.

3.	 Choose Manually Collect Responses In My Email Inbox from 
the How Do You Want To Collect Responses drop-down 
menu. Click Next.

4.	 Choose Save a Local Copy and Manually Send It Later and 
click Next.

5.	 Click Finish on the Distribute Forms screen. You’ll now 
have the following additional PDF files in the folder 
where you copied the PDF file:

88 [form name]_distributed.pdf
88 [form name]_responses.pdf

	 These two files, together with the PDF form file, 
should be retained all through the registration drive. 
Responses that you receive will be added to the  
[form name]_responses.pdf file and will also be visible 
through the Adobe Tracker.

6.	 Upload the [form name]_distributed.pdf file to the 
conference website, so that it is available to users for 
download and submission.

Figure 3. Adobe Tracker
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Figure 4 shows this logic implemented using basic 
JavaScript constructs. I used this script for the FeeRadio 
radio button group for three events—Enter, Change, and 
Click. You can select events using the Show drop-down 
menu in the script editor (labeled SE in Figure 2).

As an exercise, study the sample form for more 
examples of field-level scripting.

(Advanced) Analysis and Reporting 
Possibilities
Once you export the received form data as XML in Adobe 
Tracker, it is possible to generate a wide variety of reports 
from the XML file using XSL Transformations (XSLT). 
A fuller discussion of such transformations is beyond the 
scope of this article.

Further reading
44 LiveCycle Designer ES2 Help(http://help.adobe.com/en_US/
livecycle/9.0/designerHelp/index.htm)
44 The Creating a Purchase Order form tutorial (http://help 
.adobe.com/en_US/livecycle/9.0/lcdesigner_qs_poform.pdf) gi

Samartha Vashishtha� (samartha@adobe.com) works 
on the Community Help and Learning Resources team at Adobe 
Systems, India. He is also a bilingual poet, writing in English and 
Hindi, and an intermittent technology journalist. His blog about 
all things Adobe is at http://blogs.adobe.com/samartha or fol-
low him on Twitter @samarthav.

Archiving Responses
Whenever required, you can use the Archive option (see 
Figure 3) in the Adobe Tracker to create a consolidated 
archive PDF ([form name]_archive.pdf) containing all 
received responses. You can also use the Export option in 
the Adobe Tracker to export the responses in one of the 
following formats:

44 A CSV spreadsheet that can be edited using spreadsheet 
applications
44 An XML file that can be manipulated further. See 
(Advanced) Analysis and reporting possibilities.

Recommended Practices
44 After distributing the form, do not modify or fill 
information into the [form name]_distributed.pdf file 
until it is uploaded or saved in a shared location.
44 Add the received responses to the [form name]_
responses.pdf file as regularly as possible.
44 After adding one or more completed forms to the [form 
name]_responses.pdf file, save the file before exiting 
Adobe Tracker. 
44 Backup the [form name]_responses.pdf file regularly to 
prevent any data loss.

(Advanced) Using Scripting for  
Conditional Fields
Thoughtful use of scripting goes a long way when you’re 
creating PDF forms. While LiveCycle Designer offers 
extensive scripting capabilities for power users, even users 
new to programming can leverage simple JavaScript and 
FormCalc constructs to build intelligence into their forms. 
In particular, I find the ability to create conditional fields—
fields that accept input or become mandatory fields based 
on the selection in a radio button group—very useful. 

Consider the following logic for the FeeRadio radio 
button group in the sample form:

44 If users indicate that they are exempted from paying 
the registration fee, they must enter the details 
of exemption. At the same time, Conference Fee, 
Workshop Fee, and all fields in the Payment Details 
section should no longer accept input.
44 On the other hand, if users indicate that they are 
not exempted from paying the registration fee, the 
ExemptionDetails field should no longer accept inputs. 
Conference Fee, Workshop Fee, and all fields in the 
Payment Details section should be open to input. In this 
case, users must enter a valid value in the Conference Fee 
field and select one of the available modes of payment.
44 Users should be allowed to change their selection. 
For example, if some user selected “Exempted” 
remembering that they had a privilege coupon, only to 
realize that the coupon expired, they should be allowed 
to select “Paid” instead. Any “details of exemption” 
entered in the moments of indecision should be cleared 
when the user selects “Paid.”

Figure 4. Implementing conditional fields using basic scripting
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